Why?

The Global Protect VPN client is now in use at WPI. It was made available spring 2020, and has increased capacity for secure remote connections to the WPI network.

Impact

Pulse Secure is being discontinued for WPI VPN connections, and the clients are no longer receiving updates or maintenance.

Action Needed

Computers managed by WPI IT already have Global Protect installed. It can be selected from Programs and Apps under "Palo Alto Networks".  For personally-managed computers, please install the current Global Protect VPN client prior to the Pulse Secure retirement if you have not already done so. Actions links to information and downloads.  Uninstall Pulse Secure.